IRCu and srvX

Ask your questions about ircu and GNUWorld, share your ideas, and help the coders in their work.
weezel
Posts: 2

IRCu and srvX

Post by weezel »

Hey,

Having a small problem with IRCu and srvX. When i set the services port to 4400 i get a connection refused error from srvX when using "./srvx -f" command. however, when i change the services port in both the ircd.conf and srvx.conf to 6667 it actually goes to connect but of course thats a user port. so it wont connect sucessfuly on there. fair enough. but ive also tried 4400, 6660,6999 as services ports and none of them work (same connection refused errors)


Below are my config files:
Have i got any of this wrong?

Code: Select all

# M-Line
M:irc.weezel.co.uk:217.155.137.177:weezelnet:4400:1


# A-Line
A:This is Debian's default ircd configuration:Please edit your ircd.conf file:Contact <root@localhost> in case of questions

Y:1:90:0:252:500000

Y:2:90:100:0:4000000

I:*@*:3:*@*::1

# I-Line
I:Resolved::*@localhost::1
i:*@*:1:Unresolved::1
i:Resolved::*@*::1

# P-Line
P::::6667


C:217.155.137.177:PASSWORD:Services.weezel.co.uk:4400:2

N:217.155.137.177:PASSWORD:Services.weezel.co.uk::2

U:Services.weezel.co.uk:*:*


O:*@*.zen.co.uk:PASSWORD:weezel::1



and srvX

Code: Select all

"uplinks" {
    "private-network" {
        // IP address and port the server listens on
        "address"        "217.155.137.177";
        "port"           "4400";
        // What password should we send when we connect?
        "password"       "melons";
        // What password should we require our peer to send?
        // (If it is blank, we do not require a specific password.)
        "their_password" "melons";
        "enabled"        "1";
        // How many times should we try to connect before giving up?
        "max_tries"      "3";
        // What IP should we bind to?
        // If you do not specify bind_address, the default is used.
        // "bind_address"   "192.168.0.10"; // use this ip to link
   // "bind_address"   "217.155.137.177";
    };

    /* unused-uplink is just an example to show you how you can
     * define more than one uplink (and how you can disable one or
     * more of them.) */
    "unused-uplink" {
        "address"        "217.155.137.177";
        "port"           "4400";
        "password"       "PASSWORD";
        "their_password" "PASSWORD";
        // If "enabled" is 0, we will not try to use this uplink.
        "enabled"        "0";
        "max_tries"      "3";
   "bind_address" "217.155.137.177";
    };
};



"server" {
    "hostname" "Services.weezel.co.uk";
    "description" "Network Services";
    "network" "weezelnet";
    //"hidden_host" "users.weezel.net"; // set this if you enabled ircd/Undernet's +x mode
    /* hidden_host should match the F:HIDDEN_HOST: line in your ircu's ircd.conf;
     * srvx does not set the host suffix for users, but must know it when making
     * things like bans, where it should not show the user's real hostname. */
    "numeric" "10"; // hint: If you get collisions on link, CHANGE THIS.
    "max_users" "256"; // You can save a little memory by setting this to a lower value.
    "force_n2k" "1"; // Use extended (5-digit) numnick for self, even if 3 are possible.
    "ping_freq" "60";
    "ping_timeout" "90";
    "max_cycles" "30"; // max uplink cycles before giving up
    // Admin information is traditionally: location, location, email
    "admin" ("IRC Network", "Gotham City, GO", "Mr Commissioner <james.gordon@police.gov>");
    /* the following two settings are for ircu's HEAD_IN_SAND features, and are equivelent to
     * the F: lines in ircu's ircd.conf. both can be disabled by commenting them out. */
    "his_servername" "*.Generic.NET"; // hidden server name, shown in remote /whois requests
    "his_servercomment" "The Generic, Boring IRC Network";
};





Code: Select all

root@weezel-desktop:/etc/srvx# ./srvx -f 
    --------------------------------------------------
    - srvx 1.3.1 (surge), Built: Sep 29 2007, 23:36:04.
    - Copyright (C) 2000 - 2005, srvx Development Team
    --------------------------------------------------
info: Initializing daemon...
info: Loaded 97072 words into weak password dictionary.
info: Connecting to 217.155.137.177:4400...
error: Connection to uplink failed: Connection refused (111)
info: Connecting to 217.155.137.177:4400...
error: Connection to uplink failed: Connection refused (111)
info: Connecting to 217.155.137.177:4400...
error: Connection to uplink failed: Connection refused (111)
fatal: All available uplinks exhausted; giving up.

Kester
Posts: 4

Post by Kester »

AFAIK, you also have to add the 4400 port in the P-Line

P::S::4400 - not sure this is right, I stand to be corrected.

weezel
Posts: 2

Post by weezel »

Kester wrote:AFAIK, you also have to add the 4400 port in the P-Line

P::S::4400 - not sure this is right, I stand to be corrected.


Ive added port 4400 to the P line so now i have this:

Code: Select all

# P-Line
P::::6667
P::::4400


which when trying to connect srvX to ircu yields this:

Code: Select all

root@weezel-desktop:/etc/srvx# ./srvx -f
    --------------------------------------------------
    - srvx 1.3.1 (surge), Built: Sep 29 2007, 23:36:04.
    - Copyright (C) 2000 - 2005, srvx Development Team
    --------------------------------------------------
info: Initializing daemon...
info: Loaded 97072 words into weak password dictionary.
info: Connecting to 127.0.0.1:4400...
info: Connection to server established.
error: Error: Closing Link:  by irc.weezel.co.uk (Cannot connect a server to a user port)
error: Error received from uplink, squitting.
error: Disabling uplink.
fatal: All available uplinks exhausted; giving up.



i also tried P::S::4400 to no avail. any ideas anyone? the rest of the config remains the same as the above

User avatar
sirAndrew
Posts: 760
Location: Romania

Post by sirAndrew »

Are you sure those ports are opened? if you run ircu and srvx from the same host use the 127.0.0.1 as the bind adress for the services.

If you run them from different hosts, instead of srvx try running ircu, and use 4400 as the linking port. If it doesn`t work then the 4400 port is closed either form your machine or by the provider.

Hope that helps.
sirAndrew @ Undernet.org

8 years on this forum and i'm still the #1 poster around.

User avatar
Stefanoo
Posts: 127
Location: Beirut

Post by Stefanoo »

nice choice weezel, srvx rocks!
btu regarding the ircu no doubt that ircu is great but try also out ircu-nefarious.
Stefano @ Douaihy.org

User avatar
`Dan
Posts: 70
Location: Romania

Post by `Dan »

weezel wrote:
Kester wrote:AFAIK, you also have to add the 4400 port in the P-Line

P::S::4400 - not sure this is right, I stand to be corrected.


Ive added port 4400 to the P line so now i have this:

Code: Select all

# P-Line
P::::6667
P::::4400




P::S::4400 if you don't put S that port will be for clients , S means Servers/Services
#Nastrand and #Class member.