It is currently Wed Dec 19, 2018 2:56 pm

All times are UTC [ DST ]




 Page 1 of 1 [ 6 posts ] 
Author Message
 Post subject: mod.CControl bug ?
PostPosted: Sat Apr 01, 2006 8:58 am 

Joined: Sun Dec 12, 2004 12:08 am
Posts: 47
I'm not sure about this because i'm a beginner in C and C++ but i thing there is a bug on CControl module.
The function getReason() from Gline class does not return the reason of a gline that was added. It returns the timestamp (something like 1143877866).
When i saw this, i thought that something was wrong in my module, but, i took a look on the ccontrol db via phppgadmin and i saw that instead the reason of glines there is the timestamp when the glines where added. Maybe the mod.ccontrol from undernet does not have this bug, but i guess that the public version of gnuworld has it.


Offline
 Profile  
 
 Post subject:
PostPosted: Wed Apr 05, 2006 2:36 pm 

Joined: Sun Dec 12, 2004 12:08 am
Posts: 47
Wow...this is nice...no reply in 4 days...i'm curious if there will be an answer this year....i like this forum...it's like idlerpg game :lol:


Offline
 Profile  
 
 Post subject:
PostPosted: Sun Apr 09, 2006 11:57 am 

Joined: Tue Jan 04, 2005 8:20 pm
Posts: 4
Location: Belgium
To what ircu version did you link it up?
I've had troubles with linking gnuworld to asuka since Quakenet changed the gline stuff in their ircu...



_________________
4 those about to rock ...
Offline
 Profile  
 
 Post subject:
PostPosted: Sun Apr 09, 2006 2:10 pm 
Forum Moderator
User avatar

Joined: Fri Nov 19, 2004 9:51 pm
Posts: 594
Location: Europe
Hi.
ULtimaTe_ wrote:
To what ircu version did you link it up?
I've had troubles with linking gnuworld to asuka since Quakenet changed the gline stuff in their ircu...

The IRCu version is not related to what he's talking about. It's related to mod.ccontrol only.


The-Judge,
Sorry for the late reply, but I just saw this thread.

I also tried with the public gnuworld from CVS. This is what I have in the glines table in ccontrol:

 id |         host         |       addedby        |  addedon   | expiresat  | lastupdated |         reason
----+----------------------+----------------------+------------+------------+-------------+------------------------
  4 | *@test.test.123.test | mitko!mitko@test.net | 1144589620 | 1144762420 |  1144589620 | [0] this is the reason
(1 row)

Note that the reason is there, so there isn't any problem. Obviously you did some bad modifications to the code.


Best Regards,
Mit.



_________________
Dimitar Tnokovski aka Mitko
Image
Offline
 Profile  
 
 Post subject:
PostPosted: Wed Apr 12, 2006 12:52 pm 

Joined: Sun Dec 12, 2004 12:08 am
Posts: 47
Thanks Mitko but i still don't understand why in my db the reason is not the one that it should be. I'll try to reinstall gnuworld from a fresh archive.


Offline
 Profile  
 
 Post subject:
PostPosted: Sat Apr 29, 2006 12:16 pm 

Joined: Sun Dec 12, 2004 12:08 am
Posts: 47
Mitko you are right. There is no such bug in mod.CControl, but, still, i don't know why i can't get the right reason of a gline using getReason() .
I made a bot/service that "tells" on a channel details of a gline, when somebody is adding it. If i gline somebody, using or not UWorld, the function getReason() returns the timestamp of when the gline is added, but, if the proxyscan gline(version 1.x) somebody the function getReason() returns the reason as it should do.
I don't understand this...i hope that somebody will explain me...maybe Compy or...i don't know...


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 6 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: