It is currently Mon Oct 23, 2017 9:12 am

All times are UTC [ DST ]




 Page 1 of 1 [ 6 posts ] 
Author Message
 Post subject: problem when starting gnuworld
PostPosted: Fri Aug 28, 2009 1:03 pm 

Joined: Fri Aug 28, 2009 12:54 pm
Posts: 3
When i try to start GNUWorld, i get the following error:

*** [CMaster]: Attempting to make PostgreSQL connection to: 127.0.0.1; Database Name: cservice
pgsqlDB> Failed to connect to db: FATAL: role "dan" does not exist

xServer::AttachClient> Failed to instantiate module: ../lib/libcservice.la
xServer::loadClients> Failed to attach client: ../lib/libcservice.la
xServer> Failed in loading one or more modules


If someone could help, it would be greatly appreciated. :)


Offline
 Profile  
 
 Post subject: Re: problem when starting gnuworld
PostPosted: Fri Sep 11, 2009 12:34 pm 
User avatar

Joined: Mon Oct 04, 2004 3:05 pm
Posts: 65
Location: Romania, Craiova
LordWolf wrote:
When i try to start GNUWorld, i get the following error:

*** [CMaster]: Attempting to make PostgreSQL connection to: 127.0.0.1; Database Name: cservice
pgsqlDB> Failed to connect to db: FATAL: role "dan" does not exist

xServer::AttachClient> Failed to instantiate module: ../lib/libcservice.la
xServer::loadClients> Failed to attach client: ../lib/libcservice.la
xServer> Failed in loading one or more modules


If someone could help, it would be greatly appreciated. :)


Make sure you edited the configuration file with your pgsql username and password(if any)


Offline
 Profile  
 
 Post subject: Re: problem when starting gnuworld
PostPosted: Sat Nov 21, 2009 10:17 am 

Joined: Sat Nov 21, 2009 10:12 am
Posts: 3
how can i fix this? ( gnuworld starting : the first time when i start it work fine but after 3 days it go down and when i try to start again it show me this error, whithout any modification )

gnuworld: ../libgnuworld/xparameters.h:107: char* gnuworld::xParameters::operator[](const size_t&) const: Assertion `validSubscript( pos )' failed.

.........

inline char* operator[]( const size_type& pos ) const
{ assert( validSubscript( pos ) ) ; return myVector[ pos ] ; }

.........

inline bool validSubscript( const size_type& i ) const
{ return (i < myVector.size()) ; }

.........


Offline
 Profile  
 
 Post subject: Re: problem when starting gnuworld
PostPosted: Sat Nov 21, 2009 2:29 pm 

Joined: Sat Nov 21, 2009 10:12 am
Posts: 3
andrew1 wrote:
how can i fix this? ( gnuworld starting : the first time when i start it work fine but after 3 days it go down and when i try to start again it show me this error, whithout any modification )

gnuworld: ../libgnuworld/xparameters.h:107: char* gnuworld::xParameters::operator[](const size_t&) const: Assertion `validSubscript( pos )' failed.

.........

inline char* operator[]( const size_type& pos ) const
{ assert( validSubscript( pos ) ) ; return myVector[ pos ] ; }

.........

inline bool validSubscript( const size_type& i ) const
{ return (i < myVector.size()) ; }

.........


i think i found the problem for this error.
in my ircu i found 2 active gline, i was deactivating it and then i try again to start gnuworld and it work fine this time.
my queston now is, why gnuworld can't start if ircu have active gline which are not expired yet????? and can tell me what is the link between validSubscript( pos ) and glines?
ps: that glines was seted with UWorld, so gnuworld was linked to ircu in that moment...


Offline
 Profile  
 
 Post subject: Re: problem when starting gnuworld
PostPosted: Mon Dec 28, 2009 7:25 am 

Joined: Mon Dec 28, 2009 7:11 am
Posts: 1
[IN ]: AB GL * +*!*@99.148.48.47 2872 1261978994 :AUTO [2] Abusive hosts being used for flood.
gnuworld: ../libgnuworld/xparameters.h:107: char* gnuworld::xParameters::operator[](const size_t&) const: Assertion `validSubscript( pos )' failed.


The Same Problem.

The first time when i compile my server with gnuworld (2003) it works perfectly without any errors. I loose my HDD, needed to remake everything, now i have tried all the versions of GNUWorld, the same error by the xparameters.h , postgresql removed, reinstalled, all the components reinstalled, recompilded the whole GNUWorld, the same error. If a GLine is still active on 1 server in my network GNUWorld process doesnt start anymore, i must wait for the gLine deactivation.

Any Ideeas?

Problem solved.

Do not use any moded ircu or another ircd with the latest gnuworld, gnuworld can`t see g-lines on servers, use the latest original ircu.

But still gave errors, because i use all the services inside the gnuworld, mod.openchanfix if i msg to C , the whole gnuworld dies, and if C is active, D, Stats, Snoop, NetScan modules are permanently in BURST state.

I have resolved the problem combined the chanfix.la from the mod.chanfix module with the mod.openchanix module, while if i use the mod.openchanix chanfix.la C wont work, or if i use the mod.chanfix C is working but the another services are permanently in BURST mode. Finnaly i resolved the problem, C is active, but it says channel services not found, and it scores not the new channels, i have set in the chanfix configuration to point the channel services to another service ex. proxypool (pxys), restarted gnuworld, and it works perfectly, C is active scoring channels, fixes channels, D is active RUN mode, glines every flood attempt. Stats, Snoop,Netscan,testclient is working fine. No more problems.

Maybe this problems occured by me, i dont know, but i wrote this solving if someone conflicts with the same problems too.

coder
Linux C,perl coder


Offline
 Profile  
 
 Post subject: Re: problem when starting gnuworld
PostPosted: Sun May 29, 2011 9:06 am 

Joined: Sun May 29, 2011 1:25 am
Posts: 2
Quote:
Problem solved.

Do not use any moded ircu or another ircd with the latest gnuworld, gnuworld can`t see g-lines on servers, use the latest original ircu.

coder
Linux C,perl coder

That ain't a solution my friend, so the problem is far from being solver. Latest GNUWorld and Nefarious combination works great until you start setting Glines, after that, Hell is on Earth. If for some reason you need to shutdown GNUWorld (to work in the database for example) or it crashes, linked servers needs to be restarted in the same time if you want GNUWorld back, so Glines can expire.
Is 2011. The issue is still present and people are still using GNUWorld. Yet, too bad this issue appears :/


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 6 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron