It is currently Sun Dec 09, 2018 10:48 pm

All times are UTC [ DST ]




 Page 1 of 1 [ 5 posts ] 
Author Message
 Post subject: [Help] Need Help Getting DCC to work through router.
PostPosted: Fri Jan 17, 2003 11:50 pm 

Joined: Thu Jan 09, 2003 11:47 pm
Posts: 25
Location: Martinez CA
Hey y'all. I've got a question.

For security reasons (as well as the ability to share a DSL line amongst multiple systems) I'm running a broadband router. It has the ability to both DMZ (one system gets forwarded all unsolicited inbound traffic) and forward specific port traffic to seperate systems. However, it also uses NAT to 'hide' the internal network. I don't believe there's a way to turn NAT off with this router.

I understand NAT gets in the way of DCC sends... is there any way to fix this problem? I can receive DCC connections, but cannot initiate them.

Some particulars: my DSL is static IP provisioned, and I'm using non-routable IP's on the LAN portion (192.168.*.*). Two internal hosts are running Windows ME (mIRC as the client) and one is running bIRChX (sp) in the 'foundation' layer of Mac OS X (because I've yet to find a cool Max OS X IRC client yet!). I routinely use mIRC on the laptop (windows).

Any thoughts?



_________________
Biker Credo: Never ride faster than your guardian angel can fly.
Image
Offline
 Profile  
 
 Post subject:
PostPosted: Sat Jan 18, 2003 5:24 am 
User avatar

Joined: Fri Dec 13, 2002 1:07 am
Posts: 33
Location: Columbus, OH
I'm in the same boat you are, except I have a cable connection and I normally user a FreeBSD (right now it's *shudder* redhat) to share my connection with my roommates. In the past I've been able to specify ports with mIRC and with X-Chat and bounce those ports from the router to my machine and get DCCs to work. Sometimes it just doesnt' seem to be enough. :( You could try port forwarding specific ports you specify in your client to see if that works. Hopefully someone will give some more insite on this problem.


Offline
 Profile  
 
 Post subject:
PostPosted: Mon Jan 20, 2003 10:02 am 
User avatar

Joined: Fri Mar 01, 2002 1:00 am
Posts: 209
Location: Barcelona, Spain
I don't know exactly your router and your local network settings but I had the same problem (*), this is how I managed to solve it:

1.- I accessed the router's Advanced Settings and went to the NAPT (**) options. There I enabled "forwarding" to ports: 113 (identd) and picked a range of 10 ports from the DCC defaults (1024-5000), for example: 4980 to 4989. I also enabled port 59. All these to my local IP and as TCP protocol.

2.- Configured my mIRC DCC ports range to the same I had enabled in my router (4980-4989), enabled port 113 (identd). Then on Local Info, I just left it as "On connect, always get... Local Host" and "Lookup method...Server"

3.- Rebooted and it fortunately worked. It also removed the annoying ~ in front of the userid when connecting to the IRC.

Hope this helps you. You can get help online in #userguide/#help/#helpchan. Good luck.

Carlos

(*) Router is a SpeedStream ####
(**) NAPT = Network Address Port Translation


Offline
 Profile  
 
 Post subject:
PostPosted: Mon Jan 20, 2003 7:01 pm 

Joined: Thu Jan 09, 2003 11:47 pm
Posts: 25
Location: Martinez CA
Thanks Carlos. I'll have to see if I can't forward those ports over.

I've a Belkin router (!!) so I don't think it has as many choices as a Speedstream... the Efficient networks routers are the closest to 'real' routers that I've found... with prices to match.

Oh and as for the Mac, now running JediKnight 2.0. It's OK, needs some work with the console commands and such... but it shows promise. Besides, what do ya want for nothing? :D


Offline
 Profile  
 
 Post subject:
PostPosted: Sun Feb 09, 2003 2:19 pm 

Joined: Sun Feb 09, 2003 12:29 pm
Posts: 5
Nu-Hir: If you're on 2.4 with iptables (you can rmmod ipchains and load iptables if you're runing the stock kernel), you might try to load the ip_nat_irc and ip_conntrack_irc modules. Also, you need to accept RELATED connections, using the state match support. If you're connecting to IRC on non-standard ports, pass the ports option to ip_conntrack_irc, when loading it (ie, modprobe ip_conntrack_irc ports=6667,6668,6669,7000). http://www.netfilter.org or http://www.google.com for more info.

cArLiLLoS: What's port 59 for?

dcnblues: Just use an old 486, with Linux, way cheaper and more configurable. :-) As for what cArLiLLoS said, it will work, provided the client can limit itself to a range of ports. He sid mIRC can do it so BitchX remains the one I don't know anything about (which doesn't mean I know anything about mIRC). If it can't do it, take a look at irssi, http://www.irssi.org, a very nice, imho, console client. As for getting ident on the MacOS, you'll probably have to run an fake identd for that to happen, but that all depends on how your router does NAT (ie, if it changes both the source and the destination addresses, you get to run a fake identd, if not, you're lucky)


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 5 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: